2

I'm trying to upgrade my drush install on my local ubuntu machine but when I type in 'composer global require drush/drush:dev-master' I get the following error:

Changed current directory to /home/lupiyardo/.composer
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for drush/drush dev-master -> satisfiable
 by drush/drush[dev-master].
    - drush/drush dev-master requires codegyre/robo ~1.0.0-beta1 -> 
satisfiable by codegyre/robo[1.0.0-beta1] but these conflict with your 
requirements or minimum-stability.
Installation failed, reverting ./composer.json to its original content.

Ok, so I determined it meant I didn't have codegyre/robo. I was sent to this help document. I tried running composer require drush/drush:~8 and it seems to install it fine. However, after doing so when I run drush status it still shows drush version 5.10.0 as the current version.

I also tried installing codegyre/robo, like so:

composer require codegyre/robo:~1

But then I get this error:

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package codegyre/robo ~1 is satisfiable by 
codegyre/robo[1.0.0-beta1, 1.x-dev] but these conflict with your 
requirements or minimum-stability.


Installation failed, reverting ./composer.json to its original 
content.

So I'm still stuck. Perhaps I need to fix my composer.json file but I'm not sure how to do that...

So I edited my composer.json file and removed everything in there under 'require' and then ran: sudo composer global require drush/drush:8.1.2

That gave me even more errors:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Can only install one of: pear/console_table[v1.3.0, 1.2.1].
    - Can only install one of: pear/console_table[v1.3.0, v1.2.1].
    - Can only install one of: pear/console_table[v1.3.0, 1.2.1].
    - drush/drush 8.1.2 requires pear/console_table ~1.3.0 -> satisfiable 
    by pear/console_table[v1.3.0].
    - Installation request for drush/drush 8.1.2 -> satisfiable by 
    drush/drush[8.1.2].
    - Installation request for pear/console_table (locked at 1.2.1) ->
    satisfiable by pear/console_table[1.2.1].


Installation failed, reverting ./composer.json to its original content.
1
  • Comments have been removed. Please don't use them for extended discussion. Comments are not for interactive debugging session, but you can use the chat room, if you need it. If you can make this question a new question, and not a duplicate of the other question, edit the question; don't add comments, for which the purpose is another one.
    – apaderno
    May 12 '16 at 6:52

Browse other questions tagged or ask your own question.