0

So if I am in my admin section

http://example.com/admin/content

and I try and click on

http://example.com/admin/structure

The url is

http://example.com/admin/admin/structure

I set the base_url but it keeps happening, is there a setting somewhere (in the table or in the admin) where I can edit it?

The base url is

$base_url = 'http://example.com';

2
  • 1
    I guess you've got something in .htaccess/vhost config doing the redirect, or a dodgy contrib module/configuration to do with the same. Drupal doesn't have that behaviour out of the box so you need to hunt down what's different about your site
    – Clive
    Commented May 12, 2016 at 10:45
  • The base url is fine, updated the post.
    – LeBlaireau
    Commented May 12, 2016 at 10:46

1 Answer 1

0

And at the front of this problem is not present? If this problem only in the admin area, then you may have incorrectly configured htaccess or problem in a certain module. Because server settings I think this should not be, but it can be. Therefore, try to deploy the site on another server environments.

4
  • It has been deployed on a digital ocean droplet and locally with the same issue.
    – LeBlaireau
    Commented May 12, 2016 at 12:08
  • Start disabling modules one-by-one until you find the culprit @LeBlaireau, it's very unlikely anyone will be able to guess what the issue is from here
    – Clive
    Commented May 12, 2016 at 12:27
  • Cheers Clive, you are right it is going to be a process of elimination!
    – LeBlaireau
    Commented May 12, 2016 at 12:35
  • Well, to solve the problem, you can then disconnect modules. But the fact that they have a problem. htaccess tried to rule?
    – Wise Ltd.
    Commented May 12, 2016 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.