1
composer global update

Changed current directory to /home/ckosloff/.composer Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - drush/drush dev-master requires codegyre/robo ~1.0.0-beta1 -> satisfiable by codegyre/robo[1.0.0-beta1] but these conflict with your requirements or minimum-stability. - drush/drush dev-master requires codegyre/robo ~1.0.0-beta1 -> satisfiable by codegyre/robo[1.0.0-beta1] but these conflict with your requirements or minimum-stability. - Installation request for drush/drush dev-master -> satisfiable by drush/drush[dev-master].

The above is what I get when running composer global update.

Steps taken:

  1. I updated composer to latest build via self-update
  2. I added the line minimum stability:"dev" to composer.json

Drush is not getting updated to the latest version.
How can I solve this?

  • either install codegyre/robo ~1.0.0-beta1 OR run composer require drush/drush:~8 and use the stable release of Drush. – No Sssweat May 16 '16 at 3:54
  • THe json syntax was wrong, as the error suggested after I added "minimum-stabilty":"dev", the line is correct , but he json syntax was not, I got support in #drupal-support, many thanks to user mchelen. I also learned about json syntax, it has its own peculiarities. – Pikoro Daimaku May 19 '16 at 12:51

Browse other questions tagged or ask your own question.