0

When I try to place new block by clicking "Place block" button or when I click "Configure" on the block I see no pop-up window as I see in tutorial videos, like here: https://www.youtube.com/watch?v=D2KvCGGtBuk 3:10 and 4:25. It seems that this problem is persistent in other administration menus (like views, when I try to choose view format). How do I enable them? Why aren't they shown?

I'm on Drupal 8.1.1, with Nginx web server, Ubuntu 14.04 x32, DigitalOcean. There are no errors in status report except not protected configuration files and trusted host settings, which will be solved when site opens to public.

  • 1
    That video does not show Drupal's default behavior. The overlay is probably the result of a contributed module. So there is nothing wrong with your install, you only have to find the module that enables this. You should be able to complete all steps of the video in the 'main window'. – Neograph734 May 19 '16 at 12:39
  • I would like to find out what module enables this. Strange that with default installation I don't have full functionality. I didn't understood what do you mean by saying 'main window'? – Neone May 19 '16 at 12:54
  • When I click "Place block" in Blocks or "Choose view format" in Views, there is no new window. – Neone May 19 '16 at 12:57
  • Oh, my bad... I skipped to 4:25 which gives the exact same window as when you would have clicked configure, but the configure button opens the page fullscreen (not in overlay). That is what I meant with 'main windows'. The place block button indeed opens a pop-up. Any messages in your javascript console? Open the browser's developer tools and navigate to the Console tab. – Neograph734 May 19 '16 at 13:00
  • AJAX Error pastebin.com/rUBvAVj2 – Neone May 19 '16 at 13:06
1

The block layout is in the standard installation of drupal. This popup should work out of the box.

When you press the button "Place block" this ajax is used:

/admin/structure/block/library/mytheme?region=header&_wrapper_format=drupal_modal...

So I would check first if this ajax is fired and second if there are any js errors in the browser debug tool (F12).

| improve this answer | |
  • AJAX Error pastebin.com/rUBvAVj2 – Neone May 19 '16 at 13:05
  • That's interesting. You can see that the server response is there with all block data and the command to open the modal window. Why this is not happening in your browser, I don't know. Did you try a different browser? – 4k4 May 19 '16 at 13:09
  • Solved. That was Google Analytics code which called error. Removed it from root index.php file. Where it needs to be put? – Neone May 19 '16 at 13:10
  • 1
    That's another question, but not in the index.php. – 4k4 May 19 '16 at 13:15
  • I use Bootstrap subtheme. Do I need to create subsite in sites directory? – Neone May 19 '16 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.