1

Well after 3 days of headsmahsing against this issue and trying to resolve it by reading the documentation available, I think it’s time to expose my problem. ^^

Every time I try to create a new web site from acquia dev top, at the database configuration step, it doesn’t set up the database at all and give me directly “Drupal is already installed”.

When I try to view my “existing site”, I have “The website encountered an unexpected error. Please try again later”.

This problem occur with every version of drupal, and every version of php I try to install. Trust me I try every combination, and of course I have try the right configuration first, as describe here: https://www.drupal.org/requirements.

Of course, I have also tried what is indicated: • “To start over, you must empty your existing database and copy default.settings.php over settings.php.”

I have delete the previous database, and copy default.settings.php over settings.php. But it’s just bug and give me :

Échec de connexion à votre serveur de base de données. Le serveur retourne le message suivant : SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: H�te inconnu. .

I also try to desinstall and reinstall acquia dev top (with the last version up to date). Every dev desktop folders and files have full authorization.

It’s really weird, because 3 days ago, I created and installed a local web site with drupal 8 with acquia dev top. It worked perfectly fine, until I mess up by installing a wrong theme (^^). After that, every time I try to create a new site, I obtain the result as described before.

My last guess is that the problem is inside Phpmyadmin. Anyone have a suggestion ? ^^

I am running out of option, and I think I will turn to another solution than Acquia Dev top.

Thanks for your attention and consideration.

  • 1
    Acquia dev desktop changes your settings.php to include another file where your database credentials are saved. If you change settings.php with the default.settings.php, this line might be missing. So don't do that. Remove the sites and databases so you have a clean install. Download a new site, do not start the install. Check the settings file and the included file for database credentials. Ensure those are valid for the given database. Finally acquia has a support forum for dev desktop. You might find something there. It sounds like a bug to me... – Neograph734 May 20 '16 at 22:37
  • Hi. Thanks for your answer, but I have already tried all of this. And I begin to think that my problem is in Phpmyadmin, so acquia wont be much of help, but who knows, I have also left a message on their forum. – Pierre Noel May 22 '16 at 13:47
  • 1
    Phpmyadmin is only a layer above MySQL, to make it easier to view and modify data for people. Acquia dev desktop and Drupal do not use that in any way. To me it seems there is an error with the database settings. (It would be usefull if you had an english translation of the error message.) Therefor I recommended to see if the included settings file in fact contains data. – Neograph734 May 22 '16 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.