I keep getting this AJAX error message every time when I add taxonomy terms or open view pages with AJAX, to name a few.

An AJAX HTTP request terminated abnormally.
Debugging information follows.
Path: /system/ajax
StatusText: error
ReadyState: 4

Any suggestions to how I can resolve the problem? I'm using the dev desktop.

  • Do you frequently update your modules? Its a relative common problem, which will get fixed soon, if its a popular module you are using. However, you should probably try to locate the problem a bit further!
    – jumper
    Jan 20, 2012 at 1:33
  • 1
    For Drupal 7 you may try to apply the following core patch: D7-fix_autocomplete_terminated_error-1232416-179-do-not-test.patch.
    – kenorb
    Jun 28, 2014 at 8:34

3 Answers 3


This issue sounds like yours: Drupal alerts "An AJAX HTTP request terminated abnormally" during normal site operation, confusing site visitors/editors


For Drupal 7 you may try to apply the following core patch: D7-fix_autocomplete_terminated_error-1232416-179-do-not-test.patch which goes like:

--- a/misc/ajax.js
+++ b/misc/ajax.js
@@ -448,7 +448,10 @@ Drupal.ajax.prototype.getEffect = function (response) {
  * Handler for the form redirection error.
 Drupal.ajax.prototype.error = function (response, uri) {
-  alert(Drupal.ajaxError(response, uri));
+  // Fix for autocomplete terminated error.
+  if (response.status != 0) {
+    alert(Drupal.ajaxError(response, uri));
+  }
   // Remove the progress element.
   if (this.progress.element) {
diff --git a/misc/autocomplete.js b/misc/autocomplete.js
index 8f7ac60..980c1ca 100644
--- a/misc/autocomplete.js
+++ b/misc/autocomplete.js
@@ -306,7 +306,10 @@ Drupal.ACDB.prototype.search = function (searchString) {
       error: function (xmlhttp) {
-        alert(Drupal.ajaxError(xmlhttp, db.uri));
+        // Fix for autocomplete terminated error.
+        if (xmlhttp.status != 0) {
+          alert(Drupal.ajaxError(xmlhttp, db.uri));
+        }
   }, this.delay);

I have also been seeing this lately. Mine popped up immediately and did not have the turning indicator at all.

I have come to a post at Required autocomplete reference field gives "ReadyState: 0" ajax error #5 @jenlampton gave ma a Clue as to my problem. Although I did use http and not https, I used a link without the www as referenced in my settings.php configuration.

Adding www in my browser made the error disappear.

In conclusion, check your settings.php configuration where $base_url = 'http://www.example.com" if you have https use https, if you have www.example.com do not go to example.com.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.