My <front> and <none> route is now using one of my view path... I think it's because I delete the default home view.

I don't need it because my home page is a Panels Page...

How to set the <front> route to use an other path ?


Exemple: i've a view called myContentAdminView, with this url defined : /my-content-admin-view.

if i look in the bdd, in the router table, the both path of the front> and none> route are set to /my-content-admin-view. this values are sync with the url view, i don't know why and how to change that.

The front> is use for exemple when you disconect. The none> route is use by the MenuBlock to check if a user has the right to see a link with no route (like this one : '#a-anchor-link')

  • You want <front> to be your panel page? or something else?
    – No Sssweat
    May 23, 2016 at 15:09
  • it's already done in the base site parameters configuration. But the <front> route is the one use for exemple when you are disconected, aperently.
    – Cawet
    May 23, 2016 at 15:11
  • Also when you add a link in a menu tree with a url like this : "#my-anchor-link", the system check the <none> route to see if a user can see it. For me anoymous people can't see the link...because the <none> route is attached with a administration view xD
    – Cawet
    May 23, 2016 at 15:12

1 Answer 1


The defaults for these routes are defined in system.routing.yml:

  path: '/'
    _title: Home
    _access: 'TRUE'

  path: ''
    _no_path: TRUE
    _access: 'TRUE'

The router table is rebuilt every time you clear the cache. Then all static routes defined in yaml-files are collected and put in the router table.

If you get other path values for these routes, then you must have overridden this somewhere, for example in a view.

This has nothing to do with the setting in site configuration.

If you a looking for a specific path you can search in all *.routing.yml files for the static routes. Most of the dynamically generated routes probably are somewhere in the config files. You can export the full config of your site (admin/config/development/configuration/full/export) and search there for a specific string.

  • yes, I think i did it in my view, because it's the path of my view. How did i change that? I don't remember did anyting about that expect to delete the home page view. I don't found any option about it :s
    – Cawet
    May 23, 2016 at 17:43
  • I added some ideas how you can try to find the path.
    – 4uk4
    May 23, 2016 at 19:03
  • I allready search in those file...nothing founed. It's someting else. It's using a specific bloc in a specific view, since i deleted the front page.
    – Cawet
    May 26, 2016 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.