I installed the Superfish Module and Library and it works on a desktop/laptop/tablet. It collapses correctly when I re-size the screen. But it won't display at all on a mobile device. I tried different settings on the Config page and tried adding the recommended code in html.tpl.php: meta name="viewport" content="width=device-width, initial-scale=1.0" I enabled SF-Smallscreen with the jQuery sf-Smallscreen plugin. Made sure it was weighted to appear at the top of all the blocks. Still no luck.

1 Answer 1


My bad, I discovered my .css for the page was HIDING Superfish. Removed the offending code and Superfish on mobile works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.