0

The body area of my node is set to WYSIWYG. When I enter in HTML formatting (using the WYSIWYG buttons), it doesn't make it to the content type template:

print $node->content['body']['#value'];

Why doesn't the HTML come through? How can I print the node body to the page and preserve the HTML formatting? What am I doing wrong here?

Thanks!

1 Answer 1

2

Your input format is likely "Filtered HTML", or something other than "Full HTML". Check the input format (below the body textarea when editing the node).

4
  • Hmm... I have a custom editor profile that I'm using. I just checked its settings though. I don't see a filtered/full HTML toggle anywhere. Where is that setting? Thanks!
    – Sam
    Commented Jan 20, 2012 at 17:10
  • You are most likely looking at the wrong place. You have to check the input filter. Make sure it's not stripping the html code. I always create a Full HTML filter with no filters attached to get this working.
    – BetaRide
    Commented Jan 20, 2012 at 18:53
  • I see Input Formats... but no Input Filter. Where should I be looking?!
    – Sam
    Commented Jan 20, 2012 at 19:14
  • Wait. Nevermind. You're right it was a filter! Turned that bad boy off and voila!
    – Sam
    Commented Jan 20, 2012 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.