-1

I ran into a database problem that required me to reinstall Drupal on my Localhost. In the process, I've noticed that the custom modules I installed previously are no longer listed. They still reside in sites/all/modules and I assumed that they would show up again in my module listing after I reinstalled.

That's not the case. I cleared cache assuming that would help, but, it didn't. I ran update.php and that did not help. Is there a way to force Drupal to recognize all of the previously installed modules? Is there a database/table I need to rebuild?

4
  • 1
    Could you expand on what you mean by "reinstall"? As in what's the process you've followed to do that? If you've just installed a new version of Drupal from scratch (I.e. run through the usual installer), then you just have a fresh version of Drupal and no, it couldn't know about the modules you used to have enabled in a previous installation. It's a blank database with core Drupal in it, nothing else. If you've followed some sort of config backup/migration process, it's important to know what that was to be able to advise
    – Clive
    May 30, 2016 at 20:33
  • @Clive First, I uninstalled Drupal using the provided uninstaller (Windows). Then, I went to the Bitnami Drupal Stack and downloaded the latest Windows Installer and ran it. It installed without errors. I should also note that the uninstaller asked to make a backup of the previous Drupal database. I did make a backup.
    – rrirower
    May 30, 2016 at 20:48
  • I'm not familiar with the Bitnami stack, but I assume it contains an SQL server of some sort (probably MySQL), you didn't connect it up to an external db server? If so then that server, along with all its data, would almost certainly be removed during an uninstall. That's the usual way of things when one of these bundled things gets removed. That's probably why it suggested a backup, knowing it was going to delete everything. Your best course of action would be to restore the db backup to the newly installed server. Not sure what tools Bitnami gives you for that, but MySQL/drush will do
    – Clive
    May 30, 2016 at 20:58
  • @Clive would that also explain why the custom modules I wrote are not showing up? They are not listed in the modules screen even though they are in the correct folders.
    – rrirower
    May 30, 2016 at 23:30

1 Answer 1

0

I have resolved this issue. My problem was caused by reinstalling the Bitnami stack. I had assumed that it would install into the previous location. However, that was not the case, as I learned, because it was a newer version. Bitnami installed into an entirely separate folder. This meant that Drupal was no longer aware of my custom modules, or, the modules I had installed. My resolution was to copy my custom modules from their prior folder location to the new Bitnami reinstall location (folder). I also had to reinstall the other custom Drupal modules.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.