0

I use Drupal 7.9 and Boost 7.x-1.x-dev

Last month i disabled Boost. I used only core caching with the all options are enabled. And min cache 6 hours, max cache 1 day.

Then without chancing core cache settings i enabled Boost module. I didn't change any setting. - Cache specific pages: All pages - Cache HTML output, usually a webpage of type text/html: Enabled, 6 hours, 1 day - Root cache directory: cache - Normal cache directory: normal

But the "html" files aren't saved to my public html folder. I have this folder: "/public_html/cache/normal/www.example.com"

But this folder only has a ".htaccess" file.

I get 25 hits in one hour, but there is no html file inside these folders.

What would be the problem. Thank you for help.

4

cache/normal/www.example.com is indeed where Boost would store your cached files.

Have you added the proper Boost directives to your public_html/.htaccess? It sometimes takes a bit of fiddling to get them right - you need to experiment by accessing the site as an anonymous user and viewing source on the returned page to see if the Boost signature is in there.

  • Thank you for reply. I changed .htaccess file in "public_html" to default one came with the Drupal installation. I got into my site anonymously, loaded same page for 4-5 times. And checked source of the webpage. There is no word "boost" or "cache" in the source. – trante Jan 21 '12 at 18:49
  • "proper Boost directives": Should i add something to default htaccess file? – trante Jan 21 '12 at 18:59
  • I'm trying these directives now: drupal.org/node/545908 – trante Jan 21 '12 at 19:21
  • I tried everything :( I added generated htaccess rules to default htaccess file's rewrite base part. I installed uninstalled installed the module. Cleared all caches, run cron job. Cleared cookies. Loaded my site ananoymously but still doesn't work. – trante Jan 21 '12 at 20:02
  • When i enable debug mode of Boost, i saw these 2 errors in watchdog: Notice: Undefined index: args in boost_deliver_html_page() (line 1248 of /home/examplecom/public_html/sites/all/modules/boost/boost.module). Array ( [cache_this] => ) – trante Jan 21 '12 at 20:02
1

Boost saves cache files in a subdir to the public files dir (cache/normal). That can be virtually any place on your server, default is /sites/default/files relative to your drupal install.

Note: Boost allow you to setup where different things is stored, so this could be an entirely different place.

  • Thank you for reply. * In my "/public_html/sites/default/files" there is no folder for Boost cache. * Also "/public_html/cache/normal/www.example.com" folder has only htacess file. I couldn't find a way to find the cached files.. – trante Jan 21 '12 at 13:15
0

Watch out on Centos for SELinux blocking write access.

In your logs you will see:

SELinux is preventing /usr/sbin/httpd from write access on the directory normal

Try setting the boolean.

# setsebool -P httpd_unified 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.