0

I'm on mac with MAMP.

I've tried to follow this : https://www.drupal.org/node/2598914 and this : Turn off Twig cache

settings.local.php (i have not cut off comments in my file) :

assert_options(ASSERT_ACTIVE, TRUE);
\Drupal\Component\Assertion\Handle::register();
$settings['container_yamls'][] = DRUPAL_ROOT . '/sites/development.services.yml';
$config['system.logging']['error_level'] = 'verbose';
$config['system.performance']['css']['preprocess'] = TRUE;
$config['system.performance']['js']['preprocess'] = TRUE;
$settings['cache']['bins']['render'] = 'cache.backend.null';
$settings['cache']['bins']['dynamic_page_cache'] = 'cache.backend.null';
$settings['extension_discovery_scan_tests'] = TRUE;
$settings['rebuild_access'] = TRUE;
$settings['skip_permissions_hardening'] = TRUE;

in y settings.php i've uncommented this :

if (file_exists(__DIR__ . '/settings.local.php')) {
  include __DIR__ . '/settings.local.php';
}

developpement.services.php :

services:
  cache.backend.null:
    class: Drupal\Core\Cache\NullBackendFactory
parameters:
  twig.config:
    debug: true
    auto_reload: true
    cache: false

I call the address localhost:8888/mysite/core/rebuild.php (in my conf/performance i've uncheck cache and i have clear all caches). But when i go to another page github signale me that i have new caches files :

enter image description here

5
  • If the file name is correct, then developpment.settings.php != development.services.yml.
    – mradcliffe
    Commented Jun 6, 2016 at 16:43
  • Copy the twig.config parameter from the default.services.yml into your development.services.yml and changed the cache property as you please. *Cache rebuild is required.
    – Eyal
    Commented Jun 6, 2016 at 21:23
  • Also you should made sure that you copied the default.services.yml to a services.yml file in the same directory.
    – Eyal
    Commented Jun 6, 2016 at 21:25
  • just follow this tutorial
    – No Sssweat
    Commented Jun 7, 2016 at 0:14
  • thanks i've copied default.services.yml to services.yml and define conf and it works :)
    – Kpone
    Commented Jun 7, 2016 at 8:04

0

Browse other questions tagged or ask your own question.