0

I have a view that I finally got to work in the view preview. Then I go to the link that should give me the same result at the preview and I get the no results behaviour. I double-checked that the view is saved and I cleared the cache. view edit page

When I visit the url in the preview area, I do not get the result in the preview. Any ideas of what I did wrong?

  • Do you visit the URL in the same session/as the same user? What does your URL actually reads? Cheers! – Stefanos Petrakis Jun 6 '16 at 21:10
  • What url are you visiting? If you visit /fivepointville/footwear then you shouldn't get the results. If you visit /locations/fivepointville/department/footwear then you should expect the same results. – Frank Robert Anderson Jun 7 '16 at 1:16
  • How did you set up your contextual filters? are they getting the values from the % ? – No Sssweat Jun 7 '16 at 4:46
  • Thanks for all your comments. I found my answer. See the solution I posted. For the sake of others who have a similar problem, I will answer your questions: 1. yes, it was the same user, same session, same browser 2. The url was /locations/fivepointville/department/footerwear 3. The filters get raw value from the url – Lonita Jun 7 '16 at 17:36
0

I found the answer. Honestly, I was being a derp and a noob. Maybe I just needed time to think about it before posting a question. I will answer it here in case anyone else runs into the same issue.

Make sure you do not have any other views using the same url pattern!

This is a view I have been trying to make work for a while because I needed to reference two different vocabularies that were attached to the content type: location and department. It proved to be slightly more complicated than a typical view because of the two vocabularies and because of Drupal 8 which I am still getting used to. I forgot to delete or disable the previous view I was trying to figure it out in. When I deleted the old view that didn't work (but used the same url pattern), everything was fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.