1

I have a multilingual site, using Drupal core 7.43 and the Redirect module, and the Pathauto module (and aliases are auto created without any problems).

Creating content translation I've got such problem: all auto created url aliases don't work.

When I change site language (as visitor) all seems Ok, I see all content has been translated. But if I (as a logged in user which is also an administrator) try to open an article (for example), or any other translated content, I am always getting "Page Not Found". Auto created url leads nowhere.

What is wrong?

Note: When I am manually adding redirect (eg. from mysite/content/myarticle_1 to node/122), I am getting error "You are attempting to redirect the page to itself. This will result in an infinite loop." When I change article language from native to "All languages" then redirect could be saved and works as it should be.

  • How are you creating those urls for "auto created url aliases"? About your " if I try to open": is that as a logged in user, or a visiotor, which I assume mean "anonymous"? – Pierre.Vriens Jun 11 '16 at 8:02
  • I am just creating a translation for content as usual and aliases are auto creating from node:title,Yes, I am talking about logged in user,moreover,user with administrative rights(administrator). – jvb Jun 11 '16 at 8:43
  • well, If you mean auto creation pattern - it's "content/[node:title]". That's all. This is configuration by default. By default there wasn't Redirect module installed in my site installation. I've added Redirect by myself. Then recreated few content translations and problem leaves the same. – jvb Jun 11 '16 at 9:28
  • Do you have the Pathauto module enabled or not? – Pierre.Vriens Jun 11 '16 at 10:06
  • What I'm figured out. When I am manually adding redirect(eg. from:mysite/content/myarticle_1 to: node/122) I am getting error "You are attempting to redirect the page to itself. This will result in an infinite loop." When I change article language from native to "All languages" then redirect could be saved and works as it should be. – jvb Jun 11 '16 at 10:10
0

Check your configuration at Configuration -> Languages -> detection and selection: the order specified there could be what explains the current behaviour in your site.

You'd have to experiment a bit with what the exact order in your case should be. In my experience, I often get these kind of issues to work by using an order like 'URL, Default, User', and not something like 'Default, URL, User'. It could well be that that is all that's needed here ... So try to experiment a bit with the various combinations in this order to see if it helps.

Note: Debugging is the art of taking away all possible causes of a problem. So sorry upfront if this answer turns out to not be the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.