0

I have the theme Bootstrap CDN 3.3.6 installed on my site and I use the appearance "Journal". How not to use the CDN maintaining the appearance "Journal" ? Thank you

enter image description here

  • I download on Bootstrap http://getbootstrap.com/getting-started/#download and I copy the folder in my sub-theme, as you can see on the screenshot.
  • I copy the file overrides-journal.min.css to bootstrap theme of css file my subtheme.
  • I added a few lines in my file bootstrap_subtheme_front_office.info, see the catch.
  • I disabled CDN in subtheme /admin/appearance/settings/bootstrap_subtheme_front_office
  • I deleted the cache.

If I erases the line stylesheets[all][] = css/overrides-journal.min.css the theme works correctly but I want to show the appearance of the theme "Journal".

If I add the line stylesheets[all][] = css/overrides-journal.min.css the theme "Journal" is not applied.

enter image description here

1
0

Get the css files , or compile the less ones , and copy them to your theme css folder , then modify your theme .info file so drupal can see the new css files

3
  • To get the look "Journal" I have to copy the file "overrides-journal.min.css" in the css file my theme and add the line "stylesheets[all][] = css/overrides-journal.min.css" my .info? – user54067 Jun 13 '16 at 16:39
  • yes , basically and disable the cdn in the settings – Malek Massoudi Jun 14 '16 at 9:59
  • this does not work, I've updated the question. – user54067 Jun 14 '16 at 12:44
0

Could the order of the css files be causing the problem. If journal overrides bootstrap, it should come after it in the .info file.

3
  • thank you it works, but glyphicon are not displayed. I've updated thequestion – user54067 Jun 14 '16 at 22:28
  • @Mathieu Could try the order like this... Boostrap, Journal, Styles – J.Floyd Jun 15 '16 at 14:49
  • Also I am not seeing the bootstap.min.css file in your css directory. You may need edit the path in your .info file like your journal one. This should ensure that bootstrap is look for the fonts in the right directory. – J.Floyd Jun 15 '16 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy