0

This is very similar to this question, except there the asker answered with a solution that is not relevant.

Scenario: made a copy of a D7 site in order to apply new theme. All content types etc seem to be fine except one. In that case the body data shows in db in field_data_body table but does not show in View or Edit mode. The node has not been saved since the issue was noticed. There is only one value of revision_id for the node, and is same on both original and copy.

Body field is set to '1' but i believe that is correct, and is the same as on the site we duplicated.

The formats on original and live are both filtered_html and again this is working for all other content types

There are not field based permission modules involved. Thoughts?

here is row from original:

entity_type    bundle  deleted entity_id   revision_id language    delta   body_value  body_summary    body_format
node    committee   0   534 2416    en  0   George ...  filtered_html

here is row from copy:

entity_type    bundle  deleted entity_id   revision_id language    delta   body_value  body_summary    body_format
node    committee   0   534 2416    en  0   George ...  filtered_html
0

At this point, the issue seems to relate to language. Both live and dev have 'en' as the default language, but any new content on dev is being created as 'und', but as 'en' on live.

By way of a test, i copied the html from the db for one of the problem nodes, pasted it via Edit and saved, and the body then showed, but in the db it was flagged as being 'und'

BINGO - we had pulled a feature on to this site from another site. The other site had all fields set to 'not translatable' (field_config table).

On this 'inherited' site, some of the fields eg Body had been set to translatable, even though there were no other languages on the site.

And yes, the feature overrode the 'translate' setting in the db (there is no where to see this in the UI).

Setting body to '1' in the db has restored body being displayed, and some sanity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.