2

I created a view for node titles only. I have inserted this view in simplenews newsletter using the Insert view module. The node title in newsletter emails are relative and broken. How do I configure my view so that absolute URls are used?

enter image description here

9

1. Add Content: Link to Content field to your View . Your view fields will look as shown below.

enter image description here


2. Make sure that your Title field is outputted as plain text. In the Content:Title field settings uncheck the checkbox "Link to the Content". This is done because you'll use plain title text as a token for the link text. Exclude Title field from display, as it will be displayed later as an absolute link text.

enter image description here


3. Create settings for the absolute link output in Content: Link to Content field settings.

Open REWRITE RESULTS fieldset in Content: Link to Content field settings and check the following boxes:

Override the output of this field with custom text (set {{ title }} as text)
Output this field as a custom link
Use absolute path

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.