2

How can I display the title in URLs instead of the taxonomy ID?

www.abc.com/search-page?tid=01 should be www.abc.com/search-page?title=this-is-the-first-post.

I am using Taxonomy Terms as Search in Views (Configure filter criterion: Content: Has taxonomy term). When I click on taxonomy, I will find more button; when I click i will find "Filter identifier" by default "tid" is present.

When i tried to change that to title, it displayed Page not found.

On Views >> Advanced >> Contextual Filters, I added the field for the title, but even this is not working.

enter image description here

Thanks

  • You can use Token to replace the tid with node title. – Gulok Jun 24 '16 at 5:16
  • @Gulok : how to use token, can u plz help me on this. Thanks ! – React Developer Jun 28 '16 at 8:00
  • you mean taxonomy title or node title? – David Mcsmith Jun 29 '16 at 11:04
  • @DavidMcsmith, term name. both will do for me, im doing this for seo friendly – React Developer Jun 29 '16 at 11:14
  • 1
    I am not an SEO expert, but I doubt that this will improve SEO in anyway as filters are not links. – No Sssweat Jun 30 '16 at 0:11
7

I have fixed this, just for other guys who are facing the same issue, I thought to post this.

  1. created a Taxonomy Page with tag selected
  2. save and edit
  3. FIELDS -> add your necessary fields
  4. FILTER CRITERIA -> add: Taxonomy term: Name (exposed)
  5. click on Advance tab to the right side
  6. RELATIONSHIPS -> add : Taxonomy term: Content with term
  7. CONTEXTUAL FILTERS -> add : Taxonomy term: Name

I'm using exposed form "Exposed form in block:Yes" to be displayed as a block and can be assigned to the page.

enter image description here

Search Result in URL : drupal-7/search-new-1?name=tag

  • Can you be more specific on "Create a Taxonomy Page" (step 1.) Do you mean a Views page? Thanks. – Sam Oct 23 '17 at 15:36
1

You can achieve this by the module - TVI

https://www.drupal.org/project/tvi

Install the module from the above link.

After enable this module, remove the filter criteria just remain the contexual filter with validation criteria of taxonomy id.

Now, go to the taxonomy edit page, there is one checkbox generated by that module, check that and select the view from the dropdown.

Clear all the cache.

This works for me, i hope this helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.