2

'Hide if empty' configuration of views is not working properly as a result all the empty fields are showing.

Is there any work around to force fully hide empty fields in the views result (Page/block) neither using the configuration under 'No Results behaviour nor using views-php/block-php?

  • Hi Lalas, you are not asking a question. If this is a bug, please handle this in de module's issue queue. If you believe this is not a bug, please change your post so it becomes an answerable question. – Neograph734 Jun 26 '16 at 9:01
  • 1
    I have edited the question for more clarity – Lalas Muathasim Jun 26 '16 at 16:35
  • Under Format>Fields>Settings, there's an extra option for "Hide Empty Fields".. It could help. – Niall Murphy Aug 26 '16 at 16:57
0

Your questions does not give much information about your view, but if you want to hide the complete output of a row (when using a table) you can do this:

You can add filter criteria corresponding to the field on which you want to hide the row . Suppose you want to hide the row if content: body is empty then you can add filter criteria as Content:Body not equal to "" (where value field should be left empty). This will automatically hide the row if the specific field is empty .

source: Hide row in view if any field is empty

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.