2

My fresh installed Drupal 8 site can't display articles that use full HTML.

Is that normal?

Using the Full HTML input format, it appears like this.

enter image description here

I have to change the input format to Basic HTML, to make the body appear.

enter image description here

enter image description here

Is my installation complete?

Notes

  • I also tried pasting a different paragraph from a different website to see what happened, but the body content did not display.
  • I'm currently using Drupal core 8.1.3. What does missing filter mean? I found this in the information of text format.

    Full HTML: Missing filter. All text is removed.

3

You have to check at least one filter in admin/config/content/formats/manage/full_html

Below image shows the default filters for Full HTML

Configuration page of Full HTML


More explanation can be found from the answer by @kiamlaluno♦

Full HTML: Missing filter. All text is removed.

Above error message displayed because there is enabled filter of a input format missing. It could be happened by uninstalling module. You can find a issue in Drupal core for this.

You can just save the input format once again, which will help to remove the reference of missing filter.

  • Thanks. The body show after the align images and caption images are selected. – bingo bin Jun 30 '16 at 6:14
  • 1
    This happens because you saved the input format containing the missing filter, as I explain in my answer. – kiamlaluno Jun 30 '16 at 8:06
4

The error message you see (Full HTML: Missing filter. All text is removed.) means that one of the filters you selected on admin/config/content/formats/manage/full_html is missing; this usually happens when you uninstall the module implementing it. As explained in Missing filters result in Exception when the format is used, in those cases, Drupal doesn't show the text using the input format containing the missing filter.

That is not a problem. Just go to admin/config/content/formats/manage/full_html and save; the reference to the missing filter will be removed, and you will be able to see the body text again. In fact, the form builder for the input format form contains the following code. (See FilterFormatFormBase::form().)

  // Create filter plugin instances for all available filters, including both
  // enabled/configured ones as well as new and not yet unconfigured ones.
  $filters = $format->filters();
  foreach ($filters as $filter_id => $filter) {
    // When a filter is missing, it is replaced by the null filter. Remove it
    // here, so that saving the form will remove the missing filter.
    if ($filter instanceof FilterNull) {
      drupal_set_message($this->t('The %filter filter is missing, and will be removed once this format is saved.', array('%filter' => $filter_id)), 'warning');
      $filters->removeInstanceID($filter_id);
    }
  }

The message clearly says The filter is missing, and will be removed once this format is saved. So, saving should fix the issue.
If this doesn't work, remove another filter from the input format, save, re-add the same filter you removed, and save again. At least, this should clear the eventual cache Drupal uses for filters or input formats.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.