1

I'm trying to understand Workbench for Drupal 7. We have a role called Content Edtior that is able to create drafts of new content and new drafts of existing content.

Our trouble happens when someone in an admin role approves their own content or creates a new draft. The entire page becomes unpublished. More over, the WB UI says the page is published, but other parts of Drupal say otherwise.

We've tried to mark these troubled items as "Needs Review" and back to "Publish". This does not work. There seems to be a disconnect operating specifically on the administrator role.

Although the workbench is showing that a test node here is published.

enter image description here enter image description here

However when viewing the page, it's shown as access denied and now is unpublished.

enter image description here enter image description here

More information:

  • Using WB 7.x-1.2 and WB Mod 7.x-1.4
  • Drupal v 7.44
2
  • Is everything "stock" (a.k.a out-of-the-box)? No modifications, or hook alters? Also what specific version of Drupal and Workbench are you using?
    – Beebee
    Jun 29, 2016 at 18:25
  • I've added versions to the question. Drupal 7.44 , WB 7x-1.2, and WBM 7.x-1.4. I've tried this in both our dev instance and a new install via drush qd -y
    – Rick
    Jun 29, 2016 at 19:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.