0

I have a site with a large number of blocks, but I just added a new one that's only supposed to show on one page but it shows on every page. If I exchange it with another block I have the same problem. If I remove a bunch of blocks the problem remains.

If I put in show on all pages except those listed, it will still show on the front page. If I only put something like about with "Only the listed pages" selected, it will still show on the front page. This is happening with different types of blocks.

I've disabled Context, and Display Suite. I've flushed the cache tons of times. What could be overriding this setting?

  • Could you give us one specific test-case? (Block settings + path to the page where it should / should not be displayed) – zwirbeltier Jul 1 '16 at 9:12
  • It's difficult because it doesn't happen with all blocks But for a block it does happen with: Pick a block that is in any region, select " All pages except those listed" on the block settings page and enter "<front>". The block shouldn't be on the front page anymore, but it still will be. You can then select "Only the listed pages" and leave "<front>" in the text box and the block will still be on all pages. – Jason Jul 1 '16 at 19:22
  • Are you 100% sure you disabled "Context"? To understand why I ask (doubt), have a look at my answer to this question ... – Pierre.Vriens Jul 26 '16 at 17:07
0

It turns out that the issue was that there was, at some point, a theme with the same name but with different capitalization. It looks like this led to inconsistent results when looking up which blocks should be displayed and when. Once I removed all the entries in the block table to the old theme the problem was resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.