1

I have a view that I set it up with Search Api and Facet Api, I couldn't display the body field of indexed nodes.

I tried to add it to the Search Api index fields but it still the same result.

1 Answer 1

3

There are 2 solutions to add body field:

  • Solution 1:

    1. Browse to search api index field configuration at /admin/config/search/search_api/index/hone_and_strop/fields
    2. Now add The main body text field from Add related fields list.
    3. Now do reindexing and you would be able to add body field into view.
  • Solution 2:

    1. Create view mode with body field in it.

    2. Now in view, use Rendered entity instead of fields.

Note: You always need to do reindexing whenever you add or remove field form search api index field configuration.

4
  • I already done that, is there any other setting to apply?
    – learner123
    Jul 1, 2016 at 11:19
  • Try using Rendered entity instead of fields in view. Jul 1, 2016 at 11:24
  • That's worked with rendred entity even if if it is not the better solution. Thank you
    – learner123
    Jul 1, 2016 at 12:14
  • OK. I have updated my answer. Kept previous solution so that any other user get to know. Jul 1, 2016 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.