7

I have just installed Drupal 8.1.3 on an Amazon instance using the instructions provided here.

I can connect via SSH (console) to my instance successfully.

However, when I try to browse my public DNS, I get:

This site can’t be reached

ec2-54-187-215-79.us-west-2.compute.amazonaws.com took too long to respond.

This is the first time I am performing this installation.

I have performed a DNS check and it says: Delegation not found at parent

I am wondering whether it is a Drupal related issue or not. How can I solve this?

closed as off-topic by Clive Jul 3 '16 at 10:59

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on programming, PHP, SQL, etc. that do not relate directly to Drupal are off-topic here, but can be asked on Stack Overflow." – Clive
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Hi, as this has turned out not to be Drupal-related I've closed it – Clive Jul 3 '16 at 11:22
7

It's because by default port 22 (SSH) comes open in your EC2 security group, but port 80 (HTTP) is not open.

You need to edit your security group. To get there, in your EC2 list, scroll all the way to the right and click on the blue security group name. You will be taken to your security group settings page, for inbound, add Custom TCP Rule of port 80

enter image description here

PS: If you're going to use HTTPS might aswell open port 443 (HTTPS)

  • you are awesome this happens when i created image i forgot to create the HTTP only ssh was there by default. – Mr world wide Oct 7 '17 at 7:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.