1

This question already has an answer here:

I am in the process of recovering from a catastrophic hard disk failure on a completely new machine. I am fortunate to have both a database backup and a backup of the folder with the D7 code that was running on the original machine.

After restoring everything to the original state the site at first appeared to be running well. All nodes that I clicked on worked perfectly and showed the data I expected. The problems began when I tried to login. It looks as if submitting any form whatsoever (including the login form) does not have any effect. I couldn't even login until I generated a one time login link with drush uli. Using that link I was at last able to login with the admin user, but whenever I try to change something in the admin area I simply can't do it - the page is reloaded after I submit the form and my changes disappear. There are no error messages 1) in the web UI, 2) in the Apache log files, or 3) in the watchdog database table.

Things that I tried without any effect:

  • Clean the cache tables. All of them, both with drush and with phpMyAdmin
  • Set up a completely new site using the same codebase (Drupal 7.14). The new site works perfectly, after the setup I can login and create content without problems. The original site still doesn't work. This shows me that neither the Drupal code I am using is the problem, nor the Apache setup (the vhost for the new site is practically identical to the vhost for the problematic site).
  • Upgrade to Drupal 7.44
  • Disable all modules (only disable, not uninstall)
  • Enable tracing using the xdebug PHP module, but the result gave me information overload. I'm no PHP hacker.

I am now pretty desperate. I must overlook something essential, but for the life of me I can't find what it is. I am aware that this is all pretty vague, but I hope that someone with more experience than me can offer me a hint what I am doing wrong.

Info on my environment

  • Server
    • Debian jessie
    • Apache 2.4.10-10+deb8
    • php5 5.6.20+dfsg-0+deb8u1
    • MySQL 5.5.49-0+deb8u1
  • Client
    • Mac OS X 10.11.4
    • Firefox 46.0.1 and Safari 9.1 on Mac
  • Configuration
    • Drupal 7.14 and 7.44
    • SSL-enabled vhost

marked as duplicate by Clive 7 Jul 5 '16 at 7:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Notice also that you are stating facts, without asking any explicit question. Stack Exchange doesn't work well with implicit questions. – kiamlaluno Aug 6 '16 at 9:26
1

In your new machine you probably installed Apache and did not enable a2enmod rewrite

To enable it, copy and paste the following line to your command line:

sudo a2enmod rewrite && sudo service apache2 restart

Another way to enable it (in case you're on Windows), you could edit /apache/conf/httpd.conf and uncomment (remove the #) from #LoadModule rewrite_module modules/mod_rewrite.so line and restart Apache.

  • 1
    You are right, of course. I just gave myself a royal kick because I have seen at least 2 questions on this site that had the same solution. I dismissed the possibility that mod_rewrite could be the problem because I had set up a new site that worked - forgetting that there might be a configuration setting in the Drupal site that requires mod_rewrite. – herzbube Jul 5 '16 at 6:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.