I have a list of translated taxonomy terms (title, description, link, image). Only some of the translated terms have a value in the link field. Set up as Entity translation

My view pulls all fields and displays the default language link when no value is present on the translated term. I actually do not want to see the default link. I'd like that field to remain empty if it does not exist on the translated term.

I've deselected language fall back in the language config and set the view to hide the field if empty, but I am still showing the default language field value.

Any suggestions?


1 Answer 1


You may get it to work by using the Internationalizations Views module, which extends the i18n module with multilingual support for Views.

To make Views results correspond to the language switcher, add a filter for Content Translation: User's Current Language, which is the language that an authenticated user has set in the user settings (it is NOT the same as the current browser language or the site language).

If no option for the User's Current Language is available in the filter criteria form, then verify your configuration at Configuration -> Languages -> detection and selection: The order should be URL, Default, User and not something like Default, URL, User (as mentioned also in https://www.drupal.org/node/1701854#comment-6279474).

Note: True, the Internationalizations Views module only has a DEV / Alfa version for D7, but right now there are over 37K users using this version. Therefor I think "DEV" is not a valid release qualifier for that version anymore, because +37K users can't be wrong, right?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.