0

I moved my web server to another ip address. But "Advanced CSS/JS Aggregation" still refer the images from the old ip address. All the checkmark in my dashboard are disappeared, no matter for radio or checkbox.

Here is an example:

enter image description here

Update:
I checked the console and found an error message: "Failed to load resource: net::ERR_CONNECTION_TIMED_OUT".
Here is a screenshot for error from console: enter image description here What do I need to do??? How can I update the css and js file? Does anyone have any idea?
Thank you for all helping.

  • Every checkboxes and radios on every pages? – Jimmy Ko Jul 5 '16 at 16:38
  • yes. All pages and checkboxes in dashboard. – jmu Jul 5 '16 at 16:41
  • What's happened if you click the box? Will it show checked? Or it still in empty? – Jimmy Ko Jul 5 '16 at 16:50
  • it still empty. but when I check the source code, the box is marked as checked – jmu Jul 5 '16 at 17:48
  • update your js to some new version, it seems like js issue – Sugandh Khanna Jul 6 '16 at 5:28
0

Thank you for all your help. I found out the reason for a long time searching. Cause I moved an existing complicated website to a new ip address. The Advanced CSS/JS Aggregation module does affect images, css and js.

Here are some solutions that I found might be useful:

  • Check $base_url in setting.php file (might be set as old url/ domain name/ ip address)

  • Uncommend "#RewriteBase /" in .htaccess file then flushing the cache (Do not try this unless you know what you are doing)

  • Unable Advanced CSS/JS Aggregation Module (It will compass your js/css, this might cause some problem. Just unable it, use your original css file) -- This works for me.

Here are some references I used here:

  1. Need help changing domain/url on existing drupal site...

  2. images not showing / displaying after moving to localhost (Wamp Server)

  • Glad to know that you can find the clue.... – Jimmy Ko Aug 5 '16 at 15:26
  • You can also force AdvAgg to generate new aggregates from admin/config/development/performance/advagg/operations and opening the Drastic Measures fieldset and opening Force New Aggregates and click button Increment Global Counter. We had success generating new aggregates (this re-generates with new domain too). – Beebee Aug 5 '16 at 15:42
  • Thank you. Thank you for all your commands. @Beebee's method works like charming. Everything works fine right now. – jmu Aug 5 '16 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.