1

I don't know why all my edit button doesn't work since yesterday. In the log report, I got an AJAX HTTP error with 200 HTTP Code and "Invalid form POST data." message. And when I clicked any "edit" button, I received an Ajax error without any response Text: enter image description here

Here are some buttons I found which don't work any more:

  1. From Feed Import Setting (edit button doesn't work): enter image description here
  2. From Content type Adding (add existing product button doesn't work): enter image description here

Does anyone have any idea why I got this???

1

An AJAX HTTP error occurred is very general error and it can be related to many things.

Based on your provided information we can say it's a core callback (/system/ajax) and the callback exists (Result code: 200).

The main problem is that it returns the empty response. This is most likely caused by WSOD (white screen of death) which can be related to:

  • out of memory issue (increase memory_limit in your php.ini),
  • timeout issue (increase max_execution_time in your php.ini),
  • code issue (make sure you don't have any exit() or die() which terminates your code),
  • cache issue (so please clear your cache, including memcached/redit if you're using it).

To debug this, you should:

  1. Check your watchdog table for any errors (e.g. drush ws --tail --full).
  2. Check your PHP error log for any PHP errors.
  3. Use XDebug PHP extension, after configuring it enable xdebug.auto_trace parameter (only temporary), then reproduce the problem and check the trace file for more details.
  • Thank you for your response. The link is very helpful. I just reboot my server and everything works fine – jmu Jul 11 '16 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.