I have to add a new content type to my site for a new feature i'm asked. I already added two of them before (very early in the building of the site, in fact) and it worked well but this time, when i want to add a new node, my new content type doesn't appear in the list of content types (node/add).

It appears in the admin/structure/types page but not in the node/add.

I cleared the cache and rebuild permissions but nothing happened.

I also tried to create a very basic new content type but it didn't appear either.

An earlier exchange on this forum showed it wasn't likely to be the taxonomy access control module.

If I do a clean install of drupal and create a new content type, it works but on my site, i can't do it so i don't think it is because i forgot some step.

May it be because of some problem with a third party module ?

I don't think i have installed very exotic ones but i have some (CKEditor, Taxonomy access control, Piwik Web Analytics... )

I'm turning mad so if someone has some clue, it may really help.

Thank you

  • I guess, you would have checked this. But you can recheck at permission for adding content at admin/people/permission/Node.
    – CodeNext
    Jul 8, 2016 at 18:48
  • I rechecked but permissions were OK
    – Jice
    Jul 9, 2016 at 0:04
  • Try the following option, Go to structure>menus>navigation>list links, Then check under the Add Content option your newly created content is appearing there and it is enabled. Why because the Add Content menu is there, hence good to check there.
    – CodeNext
    Jul 9, 2016 at 0:18
  • if you can see your content type link under Add content, if it is enabled, you can disable->save configuration and again re-enabled and clear cache. This should work. Other think you can try is remove the underscore from your machine-readable name, e.g. if you content type is Article New, so by default drupal will give machine-readable name article_new, so change the MR name like articlenew.
    – CodeNext
    Jul 9, 2016 at 0:34
  • 1
    Is this about Drupal 5, or any release above that? Jul 9, 2016 at 13:29

1 Answer 1


After following clues mentioned in the above comments (by CodeNext), I was able to solve my problem. The issues and the solution I have compiled as below.

There were two problems.

  • For some needed reason, I displaced the "add content" menu from "Navigation" to "Redaction" (a new menu). This caused the new content type not appear in the "Add content" page. By displacing the new content type in the "add content" menu, I could see my new content type in the right place.
  • I had a underscore in the content type machine name. Because of this, i couldn't navigate to the node/add/newcontenttype page (I reached the node/add page). By removing it (the underscore), everything goes now the right way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.