0

All the nodes of my Hebrew site using Drupal 8 have this problem: Their address is similar to www.example.com/he/node/1, instead of what I was used to in Drupal 6+7 that was www.example.com/node/1. The difference is that now the URLs contain /he/ which I have never added.

It happens even when a node (whenever written in Hebrew or English) has its language set to English or Not specified.

What I tried is the following:

  1. At the start all, my nodes were set to Hebrew so I thought it could be the behavior of the new language system of Drupal 8. I thus changed all nodes written for English speaking audience from Hebrew to English; I flushed the cache, but it didn't help: These nodes still had /he/ in their URLs.

  2. I thought the Alternative hreflang module could cause this, so I removed it, but the problem persisted after flushing the cache.

1

Try deactivating the URL detection method under admin/config/regional/language/detection.

1

Do you have just Hebrew or are there any translations? If you have translation you should not turn off URL detection for languages. Instead, you can change the domain prefix in the language settings for Hebrew to have no domain prefix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.