1

I just recently uploaded my D7 site to a remote server and now seem to have long wait times to do anything. I have caching turned off and am still in development mode. Could it be certain modules I am using. I tried turning devel but still same wait times. What do I need to do to speed things up? everything was quick when I had the site local...

NOTE: - I am using Godaddy. i would think they have sufficient resources.

  • Try turning caching on to see if performance increases. If it doesn't at least you know it's a non-caching module that's causing the problem – Clive Jan 25 '12 at 19:29
  • 1
    Is this a server you've used before? Sounds like resources on the server to me. – Aaron Ortega Jan 25 '12 at 19:38
  • You need to profile. That will point to the problem. My guess is that the Godaddy database server is your bottleneck. Any other solutions are total shots in the dark w/o more details as to what is slow. – mpdonadio Jan 25 '12 at 22:10
1

GoDaddy is your problem. Their shared hosting does not perform well for anything that makes moderate to heavy use of MySQL. A Drupal site which is under development and doesn't employ caching often makes considerable use of MySQL queries to generate each page.

If you're still in development, I recommend working locally instead. You can install Acquia Dev Desktop to get a Drupal compatible server environment running on your machine.

Then when you're ready to go live, upload the files and publish a copy of the database to GoDaddy. Make sure all caching is enabled, and the theme registry isn't being rebuilt on every call.

Depending on the complexity of your site, however, you may still experience poor performance. Like I said, GoDaddy's shared hosting is generally not recommended for Drupal due to their poor MySQL performance. If you can, I would urge you to seek a better quality hosting provider.

  • What do you think about godaddy's dedicated hosting option? – KenAesthetic Jan 26 '12 at 18:59
1
  1. Check if you're experiencing the same issue for anonymous visitors?
  2. Try increasing php memory
  3. When was the last time you ran the cron?
1

You also might wanna check the results of Google Page Speed or YSlow and follow the recommendations given there. Both are available as add-ons to firebug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.