I have created a simple view that displays upcoming events on a page. Both the events and the pages are meant to be viewed by all site visitors. The problem that I am having is that in order to see all the events, you need to be logged into the site. I checked the nodes and permissions and don't see anything out of the ordinary. The View is supposed to display 17 events, but for the anonymous user they are only getting 12 events. Inside the view the access is Unrestricted. I have tried re-entering the 5 events that are missing and they still do not show in the View.

I also have a calendar that displays the events. Similar to the view, it is not displaying all events. The ones that are missing from the View are also missing from the calendar.

Any suggestion on what is causing this and how to fix it? Thank you.

I am using Drupal 6.2 and Views 6.x-2.16


  • May I suggest that you accept some answers to your other questions. You are much more likely to get constructive answers if you are willing to be part of the community - How to Ask
    – Chapabu
    Mar 27, 2012 at 15:16
  • I support Chapabu request..if you accept some answer it will help to the community to identify quickly what was the solution for each case. If none of the answer was helpful but you find the solution please post it and mark your solution as the the accepted answer.
    – cayerdis
    Jan 10, 2013 at 19:15

1 Answer 1


Okay, this may or may not work...but...lately D7 has a similar issue.

If you select the view, and click the link "settings" under "Query Settings", you can make the view appear by selecting "Disable SQL Rewriting". There is a security risk, and this issue needs to be solved, ex-post-haste, but it works.

This has been an issue with every View I have seen of late, provided all your permissions are legit.

  • Where do I find "click the link "settings" under "Query Settings" in Drupal 6.2 and Views 6.x2-16?
    – CD2012
    Jan 26, 2012 at 13:31
  • Do you think it has anything to do with this error message - The jQuery UI plugin is missing. Download and extract it to your jquery_ui module directory. (Currently using jQuery UI Not found)
    – CD2012
    Jan 26, 2012 at 20:49
  • I figured out that is has to do with the Protected Node module. Any suggestion on a better module that allows me to protect content from anonymous users?
    – CD2012
    Jan 30, 2012 at 0:12
  • This is true with Internal nodes too. However, using "Disable SQL Rewriting" DOES solve the problem. Don't forget to use some other protection for access (published or roles).
    – doublejosh
    Jun 5, 2013 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.