1

I keep getting User authentication failed from the Payflow server Response. I've verified the password (even have gone as far as resetting it) and I still get the same result.

I'm currently working on upgrading a D6 Ubercart site to D7 Commerce (if I can get past this one road block). I've created a new user through Paypal Manager for this module and gave it the role of API_FULL_TRANSACTIONS as suggested. Verified the user name and password but I'm still having problems authenticating apparently.

Maybe I'm not setting Payflow Link up correctly on the Commerce side? Are there any walk through or videos? Any help is greatly appreciated.

  • Are you using a paypal sandbox account for testing purposes? – No Sssweat Jul 20 '16 at 1:16
  • No, I'm using the live account that is currently working with the D6 setup. – SaintNexcis Jul 20 '16 at 14:35
  • I think that's the problem. I think you're only allowed to test using sandbox account during test mode. – No Sssweat Jul 20 '16 at 22:01
  • So after spending a few hours with TechSupport, they were abel to determine that its because the Live Site (D6) is using Legacy API for PayPal payFlow Link and therefore our payFlow Link account is linked to the legacy api and token are not used. So it's an API conflict that is not allowing the Commerce module to authenticate. – SaintNexcis Aug 1 '16 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.