0

I just enable SSL certificate for my domain. I added that in my .htaccess file:

RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} ^domainname\.com*
RewriteRule ^(.*)$ https://www.domainname.com/$1 [L,R=301]

And:

# HSTS.
<IfModule mod_headers.c>
  Header always set Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"
</IfModule>

# Cookie secure.
<IfModule mod_headers.c>
  Header set Set-Cookie HttpOnly;Secure
</IfModule>

And I changed the line in my settings.php file:

$base_url = 'https://www.domainename.com';

And :

$conf['https'] = FALSE;

All my https site displays well with the little green padlock, but the following errors appear in the dashboard drupal :

enter image description here

enter image description here

The Piwik module displays the following error:

Message d'erreur The validation of "https://analytics.s1biose.com/piwik.php" failed with error "Error opening socket ssl://analytics.s1biose.com:443" (HTTP code 0).

enter image description here

closed as off-topic by Clive May 3 '18 at 11:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on programming, PHP, SQL, etc. that do not relate directly to Drupal are off-topic here, but can be asked on Stack Overflow." – Clive
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Those two things are not related. Your SSL certificate is for inbound traffic, the errors are complaining about not being able to send outbound traffic. – Clive Jul 20 '16 at 12:25
  • @Clive ok, since this is the activation of SSL. I can not think of or comes the error. Do you have an idea ? – user54067 Jul 20 '16 at 12:34
  • @Clive it comes right SSL, because if I go to https to http, the disparraissent errors. I do not know how to solve the problem. – user54067 Jul 20 '16 at 12:49
  • 2
    You'll need to check what about your server configuration is causing that to happen, it's not Drupal doing it – Clive Jul 20 '16 at 12:51
2

There are some known issues with Drupal 7.x in some server configurations particularly around PHP 5.6 and OpenSSL 0.9x due to changes in how PHP verifies SSL certificates. Acquia has some notes about the cause and options (including a core patch to try to address some instances of the problem but read the whole article before considering that option).

On shared hosting you'll likely want to try the Alternative HTTP Client module to see if it resolves the notice.

  • can you tell me if the configuration described above is ok ? – user54067 Jul 20 '16 at 14:22
  • Given the error message it appears something is wrong. You have PHP 5.6 so the references I included may apply but you'd have to check the rest of your setup (like SNI and OpenSSL version). The module included in the Acquia article may also be worth trying to see if it can resolve the problem. – acrosman Jul 20 '16 at 14:30
  • thank you for the information but I'm on a shared server at ovh – user54067 Jul 20 '16 at 14:44
  • If you're on shared hosting, you're at the mercy of whatever server config they put in place for you. By the looks of it, their config for secure incoming connections also includes blocking outgoing connections. Getting in touch with them directly is probably the only way you'll get this solved, something will probably need to change at their end – Clive Jul 20 '16 at 17:34
  • The Alternative HTTP Client module is worth trying. I haven't used it, but in a limited hosting environment it may be your best option. – acrosman Jul 20 '16 at 18:05