0

I'm trying to add tags to my blog posts on my Drupal 7 site. I've added the Term Reference field to the content type and when I add a blog post it is letting me add tags without a problem, however despite the field being visible in the 'Manage Display' tab I can't get them to show up when viewing the blog entry.

I know that the field is working because I have the Metatag module installed and that's producing metatags from the field token. I've checked the page source though and the field isn't even there but hidden because of CSS.

Anyone any ideas?

6
  • Does it be removed in template.php or *.tpl.php?
    – Jimmy Ko
    Jul 20, 2016 at 16:25
  • Which theme are you using?
    – CodeNext
    Jul 20, 2016 at 17:07
  • Maybe you're using Panels or a template file for your node. If you switch to the drupal default theme (bartik) does the field show up?
    – No Sssweat
    Jul 21, 2016 at 2:02
  • @CodeNext I'm using a theme generated by Artisteer but I've modified it heavily. I haven't seen anything that could remove the field, but I have just switched to batik and the field does appear?
    – Andy
    Jul 21, 2016 at 9:00
  • Can you check, Setting of your theme under Appearence. And can you find whether your theme provides the option of enabling/disabling Taxonomy display. I read in one of the issue, where the theme itself was providing this feature and it was disabled and that person, did solve by this way. Might work.
    – CodeNext
    Jul 21, 2016 at 9:08

1 Answer 1

0

It turns out that my theme was hiding any term reference fields by default, which I discovered after switching back to the default theme (thank you too @NoSssweat for suggesting I do this).

I created the theme using Artisteer (please keep comments about my decision to do so to a minimum - I only use it as a starting point) and following @JimmyKo's comment I found the following lines in the node.tpl.php file:

$terms = themename_art_terms_D7($content);
hide($content[$terms['#field_name']]);

After I commented these out the term reference field started appearing. Thinking back, I may have ticked an option in Artisteer to say that I didn't want tags to appear so I can't definitely lay the blame on the software!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.