Hi I am a novice at this stuff so that might explain the following:

During my Drupal 8 install I received the following:

The libmysqlclient driver version 5.6.26 is less than the minimum required version. Upgrade to libmysqlclient version 5.5.3 or up, or alternatively switch mysql drivers to MySQLnd version 5.0.9 or up.

So when I tried to install mysqlnd it was conflicting with mysql, so I carried out the following command yum remove mysql and after removal, I installed mysqlnd with yum install php70w-mysqlnd (I have php 7 installed)

I was then able to complete the Drupal install, but when I run Drupal check, in Drupal console, it reports back:

The extension mysql is recommended to install

Then when I carry out mysql -v the reply is:

Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 22
Server version: 5.6.31 MySQL Community Server (GPL).

Any advice would be welcomed, thank you.

  • You possibly have separate .ini files for web/cli, with the extension enabled in/via the web version, but not the cli version – Clive Jul 22 '16 at 0:22
  • Hi Clive,So can you direct me as to what I can do? – Tom mcmurray Jul 22 '16 at 7:30
  • php -i |grep php\.ini will tell you what .ini file is being used, then it's just a matter of editing that file to uncomment a line like ;extension=mysql.so. That's assuming my guess was right of course, it might not be. Kind of need access to the server to be sure – Clive Jul 22 '16 at 8:01
  • Hi Clive, thank you for the info. When I check in the php.ini file mysql.so is not listed but mysqlnd.so is. I tried changing the extension=mysqlnd.so (and uncommenting) but this gave me the following. PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/msqlnd.so' - /usr/lib64/php/modules/msqlnd.so: cannot open s hared object file: No such file or directory in Unknown on line 0 – Tom mcmurray Jul 22 '16 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.