1

We have started using drush cron to manage our basic Drupal sites' scheduled tasks. I set this up using the guide at http://docs.drush.org/en/master/cron/ and it seems to be working well, except that these messages are generated on every run:

 [notice] WD Periodic: No periodic processes to run.
 [notice] WD cron: Cron run completed.

despite passing the --quiet option.

Is there a way to silence this output while still being made aware of any issues that come up with the cron task in future? We can redirect these two lines to standard out and filter on them but I wanted to find out if there is something about our Drupal setup that is causing the lines to be generated.

Our cron line is almost identical to the one in the article, but for the sake of completeness I've included it below:

0 * * * * apache /usr/bin/env PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin COLUMNS=72 /bin/drush --root=/path/to/our/drupal/site --uri=our.drupal.url --quiet cron

The drush version is 9.0-dev. Drupal version is 7.50.

Thanks for any suggestions you can provide.

3

drush cron simply calls the Drupal cron function. Drupal is initiating the watchdog messages; Drush implements system_watchdog() to convert these messages to drush log entries (Drupal 6 and 7). If you set the option --watchdog=0, then these messages will not be printed by Drush.

If there is a problem with cron, then $? should still be set to a nonzero value when drush cron exits, and the watchdog messages will still be available in the Drupal Watchdog log (visible via drush watchdog).

If you need a finer level of control over the error behavior of Drush cron, please submit a feature request in the issue queue.

  • Great, --watchdog=0 did the trick. Thank you very much. – mvermaes Jul 26 '16 at 3:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.