2

I'm working on a clean Drupal 7.x installation, downloaded Theme developer and its dependent module simplehtmldom API( another required module for Theme developer) using drush.

I found out that simplehtmldom 7.x-2.x is incompatible; so I removed it, and Installed the 7.x-1.12 version using Drush, enabled it, enabled the Theme developer module was available to be enabled. Now the site doesn't work anymore.

All I'm seeing is just some tags like this.

< /> < /> < /> < /> < /> < /> < /> < /> < /> < />

The problem is fixed when I disable the Theme developer module manually with Drush; everything gets back to normal, when I disabled that module.

I've tried to navigate the site using /node/1 and tried to go to the administration panel; all I noticed is that the title of the page (the one appearing on the browser's tab) appears but the content seems to be the same.

How do I solve this issue?

This is a screenshot.

Drupal Error devel_themer

  • This module was part of the Devel project. Now it is its own project, but relies on the Devel and simplehtmldom API modules as dependencies. If you see the page of Theme developer module, it states that sentence. Devel module is its dependency, Now if you would have downloaded Theme developer module, Drush would have asked you, "would you like to download dependencies, Devel and simsimplehtmldom API", Did you download Devel module also? – CodeNext Jul 31 '16 at 13:22
  • Yes, I have already downloaded Devel module and enabled it (Devel and Devel generate), after that I downloaded theme developer and that problem appeared. – Kareem Jul 31 '16 at 13:24
  • Which theme are you using? I just repeated the process with bartik theme and there is no issue, everything works fine. – CodeNext Jul 31 '16 at 13:33
  • Surprisingly I'm using bartik!! I've just made a new and clean installation of drupal, I haven't downloaded or edited anything except that I've downloaded the administrator's menu module, and the devel module. I'm doubting something here, I've downloaded drupal using a drush command "drush dl drupal-7.x", I've noticed that the drupal version downloaded was a dev version! could that be the problem? – Kareem Jul 31 '16 at 13:36
  • Do one thing, remove all modules, Theme developer, simplehtmldom API and Devel module. Clear cache. Then freshly, 1. Download Devel module and enable it using drush. 2. Download simplehtmldom API-a compatible version and place manually in folder, do not enable. 3. Download Theme Developer using Drush and enable using drush, then drush will automatically ask you to enable simplehtmldom API, say y for both. – CodeNext Jul 31 '16 at 13:42
0

I did manage to get it to work properly … eventually. This is how, on D7 7.5.

  1. Download and install Theme Developer 7x. Do not enable yet.
  2. Download and install SimpleHTMLDom 7.x-1.12. Do not enable yet.
  3. Download SimpleHTMLDom library from http://sourceforge.net/projects/simplehtmldom]1 and install to sites/all/libraries, so that your library path is sites/all/libraries/simplehtmldom/simple_html_dom.php.
  4. Now you can run drush en -y devel_themer and it will automatically enable the simplehtmldom.

I did notice that my /tmp folder was not giving correct permissions to the /tmp/devel_themer folder, so doing a chmod -R on that fixed the problem.

screenshot-devel_themer enabled

0

I had the same issue and I could solve it by switching from PHP7 to PHP5.6 when using the Theme Developer (7.x-1.x-dev).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.