0

I've been searching around now quite a while and couldn't find a solution that worked for me. So, here's my question:

I created a View that basically just a list of all users on my page. The view displays the

  • User name,
  • Taxonomy term and
  • User location.

For admin members the view works fine, but for non admins only the location is displayed, name and taxonomy give no results.

And,

I checked the permissions. The user is allowed to view other user profiles. He's allowed to view published content. Changing the query settings of the view didn't work

Thanks for your help.

UPDATE: In the process of elimination I checked/unchecked every single permission. The result: When I give the user the permission to Administer Organic groups permissions the user can see all the fields in the view. But I cannot allow a non admin user to administer og permissions. Any ideas why this is somehow connectd to user information fields?

0

Try the following,

There is an option in views to not take into account permissions when running the query (dunno if it is on the query level or display level though)

Edit your View at: Advanced/Query settings/, On Query settings page, check "Disable Query Rewritting"

Views UI: Advanced,

enter image description here

Query settings page,

enter image description here

  • I already tried this. It didn't work for me however :/ – Tscheckie Aug 2 '16 at 17:20
0

Okay, so here is the answer:

Go to Administration » Configuration » Organic groups » OG permissions overview » Organic groups field access and make sure all the permissions starting with "View ..." are checked for members and admin members.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.