0

I am using Group module and I have a view displaying the group members.

In a content type, I have a field where I want the members to appear in a select list so I can select one when creating the node.

Example:

**Name of the company**

list: member 1, member 2, member 3 etc
  • For that I used the Entity Reference module and added a field. In the field I chose Group members and selected the view that displays all members.

  • But when I am about to add a node, the field displays only two options, and I belive it's the two last created members.

  • If I go to www.mysite.com/name-of-the-view I can see: member 1, member 2, member 3, member 4

  • If I select the field with the exact same view I can only see member 3, member 4.

I don't know how to solve this. The view looks just fine...

Can anyone please help? Thanks

This is the view:

enter image description here

This is how it looks like in the page:

enter image description here

This is the field (as you can see with only two members):

enter image description here

  • Can you post an export, or even a screenshot of your view? – Collins Aug 4 '16 at 22:21
  • What do you have in the Contextual Filter User UID settings? – Collins Aug 4 '16 at 23:05
  • Id say its an issue with the Contextual Filter, start by removing it and checking that all users show up – Collins Aug 4 '16 at 23:07
  • Yes, I removed the contextual filter (imgur.com/a/Wlyj8) and this is what happened: imgur.com/a/tZlqo Only 2 appear as before but this time they are repeated... – Drii7 Aug 4 '16 at 23:17
  • And since I am logged in with user A, I should be able to see only the members of my group: A1, A2 and A3 – Drii7 Aug 4 '16 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.