0

I'm having difficulties with setting up Drupal 8 and Bootstrap SASS (sandbox project).

When following the documentation for setting up Bootstrap SASS at https://www.drupal.org/sandbox/wrender/2627564, when I reach point #2, "run npm install" I get lots of errors and can't proceed.

My versions

  • Mac OS X 10.11.6
  • node v0.12.7
  • ruby 2.1.3p242 (2014-09-19 revision 47630) [x86_64-darwin13.0]

Terminal output

➜ bootstrap_sass git:(master) npm install

bootstrap_starter_theme@1.0.0 postinstall /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass find node_modules/ -name '*.info' -type f -delete

npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/grunt requires minimatch@'~0.2.12' but will load npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/minimatch
npm WARN unmet dependency which is version 3.0.2
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/gulp-sourcemaps requires strip-bom@'^2.0.0' but will load
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/strip-bom
npm WARN unmet dependency which is version 3.0.0
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/gulp-watch requires vinyl@'^0.5.0' but will load
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/vinyl
npm WARN unmet dependency which is version 1.1.1
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/gulp requires vinyl-fs@'^0.3.0' but will load
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/vinyl-fs
npm WARN unmet dependency which is version 2.4.3
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/gulp-sass/node_modules/gulp-util requires object-assign@'^3.0.0' but will load
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/object-assign
npm WARN unmet dependency which is version 4.1.0
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/gulp-sass/node_modules/gulp-util requires vinyl@'^0.5.0' but will load
npm WARN unmet dependency /Users/chandeepkhosa/w/pantheon/my-website/themes/bootstrap_sass/node_modules/vinyl
npm WARN unmet dependency which is version 1.1.1

gulp-autoprefixer@2.3.1 node_modules/gulp-autoprefixer
├── object-assign@2.1.1
├── through2@0.6.5 (xtend@4.0.1, readable-stream@1.0.34)
├── vinyl-sourcemaps-apply@0.1.4 (source-map@0.1.43)
├── postcss@4.1.16 (js-base64@2.1.9, source-map@0.4.4, es6-promise@2.3.0)
└── autoprefixer-core@5.2.1 (num2fraction@1.2.2, browserslist@0.4.0, caniuse-db@1.0.30000518)
  • The link for the sandbox project is broken. Are you sure you copied it correctly? – kiamlaluno Aug 8 '16 at 1:26
  • Thank you, yes the link is correct, but since posting this the sandbox maintainer deleted it as it is no longer relevant due to a SASS starterkit being included as part of Bootstrap project itself last week. – Chandeep Khosa Aug 12 '16 at 14:41
0

I fixed this by updating my versions of NPM & Node to match the requirements stated on the project page (silly me).

| improve this answer | |
  • You're not silly, that suff should be in the package.json under engines. – Jeff Burnz Aug 7 '16 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.