4

I have an image field called field_image in a content type called Blog Post. I am able to use this field as expected, to upload and replace images, etc. I have a second content type called Event, where if I reuse this field, or even create a whole new Image field, I cannot upload an image. I get the following error in the console:

AjaxError: 
An AJAX HTTP error occurred.
HTTP Result Code: 200
Debugging information follows.
Path: /node/add/event?element_parents=field_image/widget/0&ajax_form=1
StatusText: OK
ResponseText: 


Drupal.AjaxError.prototype = new Error();

I've tried clearing the caches but that doesn't make a difference.

  • Have you checked permission for that image upload folder. And also delete that image field in blog content type and add again. Maybe this helps – Ajay Reddy Aug 9 '16 at 7:38
  • I seem to be getting this error today as well. All is the same with exception of the content type. Uploading any image to the image field results in an error with no updates to the front-end made after the error. When I check the file folder, the image is there and intact. I'm going to start a fresh install to see if I can reproduce. I'm getting these errors after installing, configuring then uninstalling crop-related modules. Creating new image fields has the same effect. – Christopher Stevens Dec 31 '16 at 18:02
  • UPDATE: So far I can confirm everything works now with a vanilla D8 install (no changes to files). I'm guessing there's something wonky with the database after installing/uninstalling Image Widget Crop and/or Crop API modules. I'll post an actual answer for future readers if I can see what's up exactly, IF this is still of interest and you followed the same path. – Christopher Stevens Dec 31 '16 at 18:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.