2

I use the Notify module. When I select for Mail System (admin/config/system/mailsystem) the choice DefaultMailSystem, the mail is sent but change line in a small border like this

enter image description here

But when I select HtmlMailSystem, it sent in a line (like what I want) but the links disappear and it looks something like this:

enter image description here

The links only appear in Gmail. In the other mails (hotmail,yahoo) they do not.

Why does this happen?

How could it be correct? In a line with links?

  • Please check my edited version of your question, and further correct/repair what I misunderstood. Also try to better describe what "we" should see in the above screenshots. True, they are not in English (they are in Greek I believe). But even if the screenprints would be in English I still wouldn't get it. Just trying to help, ok? – Pierre.Vriens Aug 9 '16 at 8:38
  • ok Pierre Vriens just a moment – nmantas84 Aug 9 '16 at 8:43
  • I change the photo to english .Do you understand now what does i mean.in first image change line before the end of line and without any symbol like "<br> \n "etc. Something like have limit – nmantas84 Aug 9 '16 at 9:18
  • Replacing the (greek) images by English equivalents did help a bit. But I think there is still a lot of extra info you did not mention (and should have mentioned ...). Curious now if the crucial information in my answer, which I think is still missing, will indeed turn out to be correct. And of course I'm also curious to hear if the rest of my answer will help you to get it to work ... – Pierre.Vriens Aug 9 '16 at 10:55
2

Your question is pretty incomplete, so let me start with adding some crucial information that I think is missing in it:

  1. Relative path admin/config/system/mailsystem is not something that gets added to a site by the Notify module. Instead that path is what gets added after you enable the Mail System module, at least for the 7.x-2.34 version of it, which is what the rest of my answer assumes you're using.
  2. After you enable the Mail System module you can navigate to the admin/config/system/mailsystem path.

    After you do so, within the settings for "Site-wide default MailSystemInterface class", you'll be able to select either DefaultMailSystem or TestingMailSystem. However you can not, repeat not, select HtmlMailSystem (as in your question).

    In order to be able to select HtmlMailSystem, you first have to enable the HTML Mail module. Which is what I did, I enabled the 7.x-2.65 version of it, which is what the rest of my answer assumes you're using.

With the above crucial additions, I think that the actual answer to your question can be found within relative path admin/config/system/htmlmail, where you can configure the settings for the HTML Mail module. I'm not sure if it's the only solution to answer your question, but pretty sure that you should select some other text filter within Post-filtering (located near the bottom within Step 3): by default it uses unfiltered, so check the results you get if you use any of the other filters you have available (or define a new filter to make it work as you want).

|improve this answer|||||
  • Nice answer but the problem is how to change the limit of the default mail? Perhaps must change a part of code,but what? – nmantas84 Aug 11 '16 at 5:32
  • Where in your original question does it ask about "how to change the limit of the default mail"? That sounds like a new question, no? – Pierre.Vriens Aug 11 '16 at 5:36
  • I think is subquestion for the solution of my first question.But I will create a new Question. – nmantas84 Aug 11 '16 at 8:57
  • @nmantas84 : ok, that would make a lot of sense, please do so. Maybe you then also want to consider marking this answer as "accepted"? – Pierre.Vriens Aug 11 '16 at 9:19
  • @nmantas84 : you still don't want to consider posting that followup-question (and mark "this" answer as accepted also)? – Pierre.Vriens Oct 3 '16 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.