I am working on a new installation of Drupal 8 (8.1.8) on a Windows Server 2012 running IIS 8. I have installed PHP v7.0.9 and MySQL v5.7.14. During the installation process, I must have done something wrong. Upon completion, the home page is just the HTML without any styling and all of the links return an HTTP Error 404.

The error: The HTTP Error

I've tried as much as I can think of (eg reinstalling IIS/Drupal/PHP/MySQL, triple checking passwords for MySQL, making sure URL Rewrite is working, etc)

UPDATE: I have also tried using drush to clear the cache.

UPDATE #2: It would seem as though my HTTP problem comes from the URL Rewrite module not working properly.

UPDATE #3: The site now has styling!!!!!! After reading this post, I realized that there was no 'tmp' directory in '/sites/default/files'. However, there is still a problem with the URL Rewrite. I have to include '/index.php' in every url to go to any pages.

  • check for apache log error , presence of .htaccess file in root folder and SWITCH ON error reporting in settings.php
    – Ajay Reddy
    Commented Aug 10, 2016 at 13:40
  • try to clean the cache, I had a similar issue yesterday and I solved cleaning the cache. Commented Aug 10, 2016 at 13:47
  • 1
    @AAjayKumarReddy I'm running IIS not Apache Commented Aug 10, 2016 at 13:51
  • @AdrianCidAlmaguer Are you talking about browser or Drupal cache? I cleared the browser with no success, but I cannot get to any of the admin pages because of the HTTP Error. Commented Aug 10, 2016 at 13:52
  • I'm talking about the drupal cache, you can install drush and use the command drush cc all Commented Aug 10, 2016 at 13:55

3 Answers 3


Probably it's a directory permission issue. Drupal is not able to write into web/sites/default/files. Give this file directory right permissions for your server user. (www-data in case of apache)

  • permissions seem to be correct Commented Aug 10, 2016 at 15:40

I don't sure if Drush works on IIS but if it works the command for D8 is drush cache-rebuild all.

However, I share the answer of ssibal check the permissions, on sites/default/files and themes/your-default-theme

  • Drush apparently works if you use Acquia Dev Desktop. I've tried clearing the cache and checking permissions. Everything appears to be set correctly. Commented Aug 10, 2016 at 15:50
  • What theme are you using? Commented Aug 10, 2016 at 15:55
  • I believe it is "bartik". This is a fresh install. I haven't been able to do anything else. As soon as the Drupal installer was finished, this is the result. Commented Aug 10, 2016 at 16:01
  • ok check out this path admin/reports/status on this path you can see the status of the website. Commented Aug 10, 2016 at 16:54
  • Still get the same HTTP Error Commented Aug 10, 2016 at 16:55

Apparently, the URL Rewrite module had become corrupted. After repairing it, I began receiving an HTTP Error 500.50. While in discussion with one of my colleagues, we learned that I needed to set HTTP_PROXY as a server variable. Then the whole thing worked!

Lots of stress off my shoulders.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.