0

As admin everything works as expected. I can upload images. As a non-admin user I can use the "Web" and "Library" functions but not the file upload function.

enter image description here

I have it enabled:

enter image description here

And the user has the correct permissions applied:

enter image description here

1 Answer 1

1

There are two things need to be configured for WYSIWYG editor.

First settings can be found on admin/config/media/browser. Either you check all available plugins like you have done in screenshot or leave all unchecked for allowing all. That's already done by you.

Next is to check permissions, where you have to give Add and upload new files, view own files etc permissions (like my screenshot below)

enter image description here

Another permission to check is Use media browser, which you must have done & so that it's appearing. Once these are in place, it should work for the role you are checking.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.