1

I'm using the Wysiwyg module with CKEditor 3.6.6.2.7696. The HTML attributes is disallowed in HTML text format, so I can't use font-size and text-align. Any solution please?

0

go to admin/config/content/formats/filtered_html

enter image description here

In the limit allowed HTML tags, add the tags that you need. You could view source to see what tags are being added when you're trying to font-size and text align and then add them here.

go to:

/admin/config/content/ckeditor/edit/Advanced (for Filter HTML)

Then under Advanced Content Filter, select disabled.

enter image description here

7
  • I mean inline css <p style='text-align:center'>, I think that's prevented by CKEditor
    – learner123
    Aug 11 '16 at 9:34
  • @learner123 Did you add <p> as allowed tag?
    – No Sssweat
    Aug 11 '16 at 9:47
  • Yes, I did, but CKEditor removes tags attributes
    – learner123
    Aug 11 '16 at 11:06
  • @learner123 try unchecking Correct faulty and chopped off HTML
    – No Sssweat
    Aug 11 '16 at 13:18
  • 1
    Sorry for my late comment, I don't have this option in my Wysiwig version, so I disabled "Verify Html" option, see the screenshot snag.gy/E1AXNd.jpg
    – learner123
    Aug 19 '16 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.