0

Once the Boost is enabled and I add its code into the .htaccess something weird starts to happen. No changes are being saved when editing the content or settings, after hitting the submit button the page just reloads ignoring the changes, no messages are shown, and sometimes the admin menu disappears. For the not logged in users the Boost works fine, html files are being generated and served. But it makes impossible to administer the site, looks like it affects the Drupal for logged in users as well or something. As soon as I remove Boost's code from the .htaccess – everything starts working again.

Using it on Apache 2.2.29

Tried to set it for the specific pages only, but had no success.

Could you help me and tell what needs to be done?

0

Did you add the Boost section in your .htaccess, which is necessary to make it work? If you already have, you might check that the part about GZIP is present.

I had this same problem, and what I did was to disable and uninstall and remove the Boost module. Then I installed and enabled the previous Boost version where this GZIP section is present. I saved that part in .htaccess and went back to installing the latest Boost version again, but with the added GZIP part in the .htaccess file.

You can also check this thread out: Impossible to edit nodes, log to in etcetera after enabling Boost and editing .htaccess

The most important gzip rules are these (if you want to try this without disabling, uninstalling and the re-installing the module:

  # GZIP
  RewriteCond %{HTTP:Accept-encoding} !gzip
  RewriteRule .* - [S=1]

  RewriteCond %{DOCUMENT_ROOT}/cache/%{ENV:boostpath}/%{SERVER_NAME}%{REQUEST_URI}_%{QUERY_STRING}\.html\.gz -s
  RewriteRule .* cache/%{ENV:boostpath}/%{SERVER_NAME}%{REQUEST_URI}_%{QUERY_STRING}\.html\.gz [L,T=text/html,E=no-gzip:1]

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.