1

I have a Content-Type called client and a Taxonomy term called Service. Inside the view I am showing content of type: node and grouping the nodes by the taxonomy reference field. Right now it is shown like this.

**Term Name1**
 node1
 node2

**Term Name2**
 node3
 node4

The problem is the term reference field is allowing multiple and I want to show the node referenced by more than one Term, under each term instead of views creating a new term grouping.

So say I reference node3 with Term Name2 as well as Term Name1 I get the following results:

**Term Name1**
 node1
 node2

**Term Name2**
 node4

**Term Name1, Term Name2**
 node3

How can I avoid this functionality and have the view show this instead?

**Term Name1**
 node1
 node2
 node3

**Term Name2**
 node3
 node4
5

In the taxonomy term's settings, you need to uncheck the option for displaying the values in the same row.

multiple_disable

1

Create a new view of content, show fields.

Under Advaced, relationship, add taxonomy terms on node and checkmark your tax term name and checkmark require relationship

In fields add field of Taxonomy term: name and checkmark hide from display

Next to Unformatted List click on Settings for Grouping field Nr.1 select (term) taxonomy term name

enter image description here

  • OP's question is about the "multiple values" option in the field's settings. Building a view like this will default to showing multiple values on the same row. I added an answer for it. – Niall Murphy Aug 14 '16 at 4:32
  • @NiallMurphy the real question is I want to show the node referenced by more than one Term, under each term instead of views creating a new term grouping. this solution worked fine for me and displayed them how the OPer asked. – No Sssweat Aug 14 '16 at 4:50
  • @NiallMurphy perhaps, your solution may solve the OPer's issue. It's hard to know not knowing how the view is set up. In my answer there is no need to do what you suggest to achieve the desired result. – No Sssweat Aug 14 '16 at 5:03
  • I just tested yours and it works as well. It's slightly limited in that it seems to need the "Require this relationship" checked to work meaning nodes with no term won't be in the view. Good to know though. – Niall Murphy Aug 14 '16 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.