2

I'm using Views Data Export to generate CSV files for end-users to use and then re-upload using Feeds. I need Vietnamese characters like â ỏ ể to be converted to a o e before export as these are in users' names.

I tried utf8_decode in Views Data Export settings but it doesn't work for all characters and even then, changing Feeds to use ISO-8859-1 still results in a "This isn't a UTF-8 file" error.

It seems that changing a setting in Excel can fix this but that isn't an option for me for usability reasons. I'm not the one who will be using these CSV files so I need these names to be exported properly.

2

Setting "Character encoding conversion" in the data export view's CSV file settings to:

ISO-8859-1//TRANSLIT

should accomplish what you're attempting. That will convert the names to the ISO-8859-1 character set, with transliteration of characters not included in the set to something that appears similar.

  • Thanks, this is a big improvement. However, there are still a few characters that come out messy.. Looking around the net, it seems that Vietnamese has too many characters for ISO-8859-1 or something like that. But it's close enough so thanks! – Niall Murphy Aug 14 '16 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.