My regions are not showing anymore in my block regions demonstration. However they are showing in my block layout.

My Regions

The regions also not display on the pages. I don't know what I did wrong. I checked the .info.yml, libraries.yml and .theme but nothing helped. I cleared the cache and still it wouldn't display.

Region demionstration What I did:

  • Cleared the cache
  • Checked info.yml
  • Checked .theme
  • Checked .libraries.yml
  • Added blocks to the regions in question

2 Answers 2


It's pretty hard to troubleshoot, but I would really recommend looking at the .theme file again. It sounds like the region is not configured/configured incorrectly there. Maybe post that here?

  • This is my info.yml: pastebin.com/i8S45phD and this is my libraries.yml: pastebin.com/wiiPfhPM. My .theme file is currently empty and its still not working.
    – G. t Cate
    Aug 23, 2016 at 7:19
  • I'm sorry I had a blank moment. I didn't mean .theme. I meant you should check page.html.twig. This is where you define how regions are displayed and where. If you've added a new region in the info.yml but not added it there, you won't see the new region. You can find the page.html.twig under templates in your /theme directory. Let me know how that goes!
    – Veez
    Aug 23, 2016 at 9:35
  • This is my page--front.html.twig pastebin.com/dbfYPUf4
    – G. t Cate
    Aug 23, 2016 at 12:55
  • In the info.yml you have custom regions called things like call_to_action and quotes, but nowhere in your twig file are you actually defining these regions (using page.call_to_action or page.quotes). This is why they won't be displaying I believe. When I was defining new regions I found it helpful to base mine off the way bootstrap did it in D8. cgit.drupalcode.org/bootstrap/tree/templates/system/…
    – Veez
    Aug 23, 2016 at 21:04
  • Those regions get called by some of the includes. I fixed it apparently it was some weird bug. I removed the blocks and added them again. I cleared the cache after it again. Any way its fixed but it is still weird. So far I could see there was nothing wrong with my blocks display settings in drupal. Thanks anyway :)
    – G. t Cate
    Aug 24, 2016 at 9:07
  1. Check in the drupal backend and with devel or kint if your regions / blocks exist.
  2. Remove the blocks in the drupal backend.
  3. Add the blocks again.
  4. Clear the cache.
  • Thanks for this. I couldn't get my regions to appear until I disabled a single existing region on /admin/structure/block
    – Will
    Jan 7, 2018 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.